<!DOCTYPE html>
<html lang="en-US">
<head >
<meta charset="UTF-8" />
<title>No need for vulgar free speech</title>		<meta name="robots" content="noodp,noydir" />
		<meta name="viewport" content="width=device-width, initial-scale=1" />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Fort Bend Southwest Star Newspaper &raquo; Feed" href="http://fortbendstar.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fort Bend Southwest Star Newspaper &raquo; Comments Feed" href="http://fortbendstar.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Fort Bend Southwest Star Newspaper &raquo; No need for vulgar free speech Comments Feed" href="http://fortbendstar.com/no-need-for-vulgar-free-speech/feed/" />
<link rel="canonical" href="http://fortbendstar.com/no-need-for-vulgar-free-speech/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/fortbendstar.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='genesis-simple-share-plugin-css-css'  href='//fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/css/share.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-genericons-css-css'  href='//fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/css/genericons.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='magazine-pro-css'  href='http://fortbendstar.com/wp-content/themes/magazine-pro/style.css?ver=3.2.3' type='text/css' media='all' />
<style id='magazine-pro-inline-css' type='text/css'>


		button:focus,
		button:hover,
		input[type="button"]:focus,
		input[type="button"]:hover,
		input[type="reset"]:focus,
		input[type="reset"]:hover,
		input[type="submit"]:focus,
		input[type="submit"]:hover,
		.archive-pagination li a:focus,
		.archive-pagination li a:hover,
		.archive-pagination li.active a,
		.button:focus,
		.button:hover,
		.entry-content .button:focus,
		.entry-content .button:hover,
		.home-middle a.more-link:focus,
		.home-middle a.more-link:hover,
		.home-top a.more-link:focus,
		.home-top a.more-link:hover,
		.js .content .home-middle a .entry-time,
		.js .content .home-top a .entry-time,
		.sidebar .tagcloud a:focus,
		.sidebar .tagcloud a:hover,
		.widget-area .enews-widget input[type="submit"] {
			background-color: #3d91e5;
			color: #222222;
		}

		.menu-toggle:focus,
		.menu-toggle:hover,
		.nav-primary .genesis-nav-menu a:focus,
		.nav-primary .genesis-nav-menu a:hover,
		.nav-primary .sub-menu a:focus,
		.nav-primary .sub-menu a:hover,
		.nav-primary .genesis-nav-menu .current-menu-item > a,
		.nav-primary .genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.nav-primary .genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.nav-primary .genesis-nav-menu a:focus,
		.nav-primary .genesis-nav-menu a:hover,
		.nav-primary .sub-menu a:focus,
		.nav-primary .sub-menu a:hover,
		.nav-primary .genesis-nav-menu .current-menu-item > a,
		.nav-primary .sub-menu-toggle:focus,
		.nav-primary .sub-menu-toggle:hover {
			color: #3d91e5;
		}

		@media only screen and (max-width: 840px) {
			nav.nav-primary .sub-menu-toggle:focus,
			nav.nav-primary .sub-menu-toggle:hover,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu a:focus,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu a:hover,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu .sub-menu a:focus,
			nav.nav-primary.genesis-responsive-menu .genesis-nav-menu .sub-menu a:hover,
			#genesis-mobile-nav-primary:focus,
			#genesis-mobile-nav-primary:hover {
				color: #3d91e5;
			}
		}

		


		a:focus,
		a:hover,
		.entry-content a,
		.entry-title a:focus,
		.entry-title a:hover,
		.genesis-nav-menu a:focus,
		.genesis-nav-menu a:hover,
		.genesis-nav-menu .current-menu-item > a,
		.genesis-nav-menu .sub-menu .current-menu-item > a:focus,
		.genesis-nav-menu .sub-menu .current-menu-item > a:hover,
		.menu-toggle:focus,
		.menu-toggle:hover,
		.sub-menu-toggle:focus,
		.sub-menu-toggle:hover {
			color: #46a1ce;
		}
		
</style>
<link rel='stylesheet' id='bne_flyouts-css'  href='http://fortbendstar.com/wp-content/plugins/bne-flyout/assets/css/bne-flyout.css?ver=1.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://fortbendstar.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='give-styles-css'  href='http://fortbendstar.com/wp-content/plugins/give/templates/give.min.css?ver=1.8.17' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='http://fortbendstar.com/wp-includes/css/dashicons.min.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C400%7CRaleway%3A400%2C500%2C900&#038;ver=3.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='views-css'  href='http://fortbendstar.com/wp-content/themes/magazine-pro/VIEWS3.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-add-custom-css-css'  href='http://fortbendstar.com?display_custom_css=css&#038;ver=4.9.1' type='text/css' media='all' />
<script type='text/javascript' src='http://fortbendstar.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='//fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0'></script>
<script type='text/javascript' src='//fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/js/waypoints.min.js?ver=0.1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var give_global_vars = {"ajaxurl":"http:\/\/fortbendstar.com\/wp-admin\/admin-ajax.php","checkout_nonce":"9dc689ec83","currency":"USD","currency_sign":"$","currency_pos":"before","thousands_separator":",","decimal_separator":".","no_gateway":"Please select a payment method.","bad_minimum":"The minimum custom donation amount for this form is","general_loading":"Loading...","purchase_loading":"Please Wait...","number_decimals":"0","give_version":"1.8.17","magnific_options":{"main_class":"give-modal","close_on_bg_click":false},"form_translation":{"payment-mode":"Please select payment mode.","give_first":"Please enter your first name.","give_email":"Please enter a valid email address.","give_user_login":"Invalid username. Only lowercase letters (a-z) and numbers are allowed.","give_user_pass":"Enter a password.","give_user_pass_confirm":"Enter the password confirmation.","give_agree_to_terms":"You must agree to the terms and conditions."},"confirm_email_sent_message":"Please check your email and click on the link to access your complete donation history."};
var give_scripts = {"ajaxurl":"http:\/\/fortbendstar.com\/wp-admin\/admin-ajax.php","ajaxNonce":"1124803bdb","loading":"Loading","select_option":"Please select an option","default_gateway":"paypal","permalinks":"1","number_decimals":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/plugins/give/assets/js/frontend/give.all.min.js?ver=1.8.17'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<script type='text/javascript' src='http://fortbendstar.com/wp-content/themes/magazine-pro/js/entry-date.js?ver=1.0.0'></script>
<link rel='https://api.w.org/' href='http://fortbendstar.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://fortbendstar.com/xmlrpc.php?rsd" />
<link rel="alternate" type="application/json+oembed" href="http://fortbendstar.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ffortbendstar.com%2Fno-need-for-vulgar-free-speech%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://fortbendstar.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Ffortbendstar.com%2Fno-need-for-vulgar-free-speech%2F&#038;format=xml" />
<meta name="generator" content="Give v1.8.17" />
<link rel="icon" href="http://fortbendstar.com/wp-content/themes/magazine-pro/images/favicon.ico" />
<link href="https://fonts.googleapis.com/css?family=Libre+Franklin:400,700,800,900" rel="stylesheet"><style type="text/css">.site-title a { background: url(http://fortbendstar.com/wp-content/uploads/2017/10/cropped-FBstar_1-7.jpg) no-repeat !important; }</style>

<!-- Flyout Custom CSS -->
<style type="text/css">
	#flyout-content-id-56984 { width:300px; left:-300px; }
	#flyout-content-id-56984 .flyout-content { color: #ffffff; }
	#flyout-content-id-56984 .flyout-content a,
	#flyout-content-id-56984 .flyout-content a:hover,
	#flyout-content-id-56984 .flyout-content a:visited { color: #eeeeee; }
	#flyout-content-id-56984 .flyout-content h1,
	#flyout-content-id-56984 .flyout-content h2,
	#flyout-content-id-56984 .flyout-content h3,
	#flyout-content-id-56984 .flyout-content h4,
	#flyout-content-id-56984 .flyout-content h5,
	#flyout-content-id-56984 .flyout-content h6 { color: #ffffff; }
		#flyout-content-id-56984 .flyout-content {
		background-color: #333333;
	}
	
</style>
<!-- END Flyout Custom CSS -->
	</head>
<body class="post-template-default single single-post postid-58221 single-format-standard custom-header header-image header-full-width content-sidebar primary-nav" itemscope itemtype="https://schema.org/WebPage"><div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><h2 class="screen-reader-text">Main navigation</h2><nav class="nav-primary" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary" aria-label="Main navigation"><div class="wrap"><ul id="menu-star-menu" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-484"><a href="http://fortbendstar.com" itemprop="url"><span itemprop="name">Home</span></a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-36"><a href="http://fortbendstar.com/category/news/" itemprop="url"><span itemprop="name">News</span></a>
<ul class="sub-menu">
	<li id="menu-item-1236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1236"><a href="http://fortbendstar.com/category/news/breakingnews/" itemprop="url"><span itemprop="name">Breaking News</span></a></li>
	<li id="menu-item-21365" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21365"><a href="http://fortbendstar.com/category/news/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
	<li id="menu-item-40" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-40"><a href="http://fortbendstar.com/category/citynews/" itemprop="url"><span itemprop="name">City News</span></a>
	<ul class="sub-menu">
		<li id="menu-item-68" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-68"><a href="http://fortbendstar.com/category/citynews/sugarland/" itemprop="url"><span itemprop="name">Sugar Land</span></a></li>
		<li id="menu-item-53" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-53"><a href="http://fortbendstar.com/category/citynews/missouricity/" itemprop="url"><span itemprop="name">Missouri City</span></a></li>
		<li id="menu-item-65" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-65"><a href="http://fortbendstar.com/category/citynews/stafford/" itemprop="url"><span itemprop="name">Stafford</span></a></li>
		<li id="menu-item-52" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52"><a href="http://fortbendstar.com/category/citynews/meadows/" itemprop="url"><span itemprop="name">Meadows Place</span></a></li>
	</ul>
</li>
	<li id="menu-item-43" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-43"><a href="http://fortbendstar.com/category/crime/" itemprop="url"><span itemprop="name">Crime</span></a></li>
	<li id="menu-item-44" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-44"><a href="http://fortbendstar.com/category/news/elections/" itemprop="url"><span itemprop="name">Elections</span></a></li>
	<li id="menu-item-1237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1237"><a href="http://fortbendstar.com/category/featured/" itemprop="url"><span itemprop="name">Featured Articles</span></a></li>
	<li id="menu-item-62" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-62"><a href="http://fortbendstar.com/category/schoolnews/" itemprop="url"><span itemprop="name">School News</span></a>
	<ul class="sub-menu">
		<li id="menu-item-46" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46"><a href="http://fortbendstar.com/category/schoolnews/sn-fortbend/" itemprop="url"><span itemprop="name">Fort Bend ISD</span></a></li>
		<li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-67"><a href="http://fortbendstar.com/category/schoolnews/sn-stafford/" itemprop="url"><span itemprop="name">Stafford MSD</span></a></li>
		<li id="menu-item-25961" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-25961"><a href="http://fortbendstar.com/category/schoolnews/colleges/" itemprop="url"><span itemprop="name">Colleges</span></a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-18770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18770"><a href="#" itemprop="url"><span itemprop="name">Opinions</span></a>
<ul class="sub-menu">
	<li id="menu-item-51079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51079"><a href="http://fortbendstar.com/category/editors-column/" itemprop="url"><span itemprop="name">Joe Southern</span></a></li>
	<li id="menu-item-55677" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55677"><a href="http://fortbendstar.com/category/theresa-mcclellan/" itemprop="url"><span itemprop="name">Theresa D. McClellan</span></a></li>
	<li id="menu-item-100" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-100"><a href="http://fortbendstar.com/category/community/letters/" itemprop="url"><span itemprop="name">Letters to the Editor</span></a></li>
	<li id="menu-item-1218" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1218"><a href="http://fortbendstar.com/category/community/editorials/" itemprop="url"><span itemprop="name">Editorials</span></a></li>
	<li id="menu-item-41" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-41"><a href="http://fortbendstar.com/category/columns/" itemprop="url"><span itemprop="name">Columns</span></a>
	<ul class="sub-menu">
		<li id="menu-item-38304" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-38304"><a href="http://fortbendstar.com/category/columns/afterburner/" itemprop="url"><span itemprop="name">Afterburner</span></a></li>
		<li id="menu-item-63" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-63"><a href="http://fortbendstar.com/category/columns/sickandtired/" itemprop="url"><span itemprop="name">Sick &#038; Tired</span></a></li>
		<li id="menu-item-27977" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27977"><a href="http://fortbendstar.com/category/columns/the-starspotter/" itemprop="url"><span itemprop="name">The StarSpotter</span></a></li>
		<li id="menu-item-6606" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6606"><a href="http://fortbendstar.com/category/columns/wolfson/" itemprop="url"><span itemprop="name">Sports Column</span></a></li>
		<li id="menu-item-42548" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-42548"><a href="http://fortbendstar.com/category/columns/dear_tabby/" itemprop="url"><span itemprop="name">Dear Tabby</span></a></li>
		<li id="menu-item-27557" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-27557"><a href="http://fortbendstar.com/category/columns/just-for-kids/" itemprop="url"><span itemprop="name">Just for Kids</span></a></li>
		<li id="menu-item-615" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-615"><a href="http://fortbendstar.com/category/columns/mclemore/" itemprop="url"><span itemprop="name">Michael McLemore</span></a></li>
		<li id="menu-item-16640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16640"><a href="http://fortbendstar.com/category/columns/telling/" itemprop="url"><span itemprop="name">Telling it like it is</span></a></li>
		<li id="menu-item-28369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28369"><a href="http://fortbendstar.com/category/columns/fort-bend-foodie/" itemprop="url"><span itemprop="name">Fort Bend Fork</span></a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-35"><a href="http://fortbendstar.com/category/community/" itemprop="url"><span itemprop="name">Community</span></a>
<ul class="sub-menu">
	<li id="menu-item-490" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-490"><a href="http://fortbendstar.com/calendar/" itemprop="url"><span itemprop="name">Calendar</span></a></li>
	<li id="menu-item-102" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-102"><a href="http://fortbendstar.com/category/community/obituary/" itemprop="url"><span itemprop="name">Obituary</span></a></li>
	<li id="menu-item-106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-106"><a href="http://fortbendstar.com/category/community/weddings/" itemprop="url"><span itemprop="name">Weddings</span></a></li>
	<li id="menu-item-99" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-99"><a href="http://fortbendstar.com/category/community/engagements/" itemprop="url"><span itemprop="name">Engagements</span></a></li>
	<li id="menu-item-522" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-522"><a href="http://fortbendstar.com/maps/" itemprop="url"><span itemprop="name">Maps</span></a></li>
</ul>
</li>
<li id="menu-item-64" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-64"><a href="http://fortbendstar.com/category/sports/" itemprop="url"><span itemprop="name">Sports</span></a>
<ul class="sub-menu">
	<li id="menu-item-45" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-45"><a href="http://fortbendstar.com/category/sports/fortbend/" itemprop="url"><span itemprop="name">Fort Bend ISD</span></a></li>
	<li id="menu-item-66" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66"><a href="http://fortbendstar.com/category/sports/stafford-sports/" itemprop="url"><span itemprop="name">Stafford MSD</span></a></li>
	<li id="menu-item-48385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48385"><a href="http://fortbendstar.com/category/sports/sports-gallery/" itemprop="url"><span itemprop="name">Sports Gallery</span></a></li>
</ul>
</li>
<li id="menu-item-937" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-937"><a href="#" itemprop="url"><span itemprop="name">Digital Issue</span></a>
<ul class="sub-menu">
	<li id="menu-item-57666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57666"><a href="https://issuu.com/sugarlandnewcomerguide.com/docs/fortbend0103" itemprop="url"><span itemprop="name">Star</span></a></li>
	<li id="menu-item-109" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-109"><a target="_blank" href="https://issuu.com/sugarlandnewcomerguide.com/docs/businessjournal-december-reduced" itemprop="url"><span itemprop="name">Busines Journal</span></a></li>
	<li id="menu-item-56966" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56966"><a href="#" itemprop="url"><span itemprop="name">Real Estate</span></a>
	<ul class="sub-menu">
		<li id="menu-item-56967" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56967"><a href="http://issuu.com/fortbendstar.com/docs/star050416/02" itemprop="url"><span itemprop="name">Finest</span></a></li>
		<li id="menu-item-56968" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56968"><a href="http://issuu.com/fortbendstar.com/docs/star050416/08" itemprop="url"><span itemprop="name">Showcase</span></a></li>
	</ul>
</li>
	<li id="menu-item-939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-939"><a target="_blank" href="http://issuu.com/fortbendstar.com/docs" itemprop="url"><span itemprop="name">Digital Archives</span></a></li>
</ul>
</li>
<li id="menu-item-941" class="menu-item menu-item-type- menu-item-object- menu-item-has-children menu-item-941"><a target="_blank" itemprop="url"><span itemprop="name">Tabs Special</span></a>
<ul class="sub-menu">
	<li id="menu-item-49453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49453"><a href="https://issuu.com/sugarlandnewcomerguide.com/docs/ncg-2017" itemprop="url"><span itemprop="name">Sugar Land Newcomer Guide 2017</span></a></li>
	<li id="menu-item-49428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49428"><a href="#" itemprop="url"><span itemprop="name">Skeeters</span></a>
	<ul class="sub-menu">
		<li id="menu-item-54860" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-54860"><a href="https://issuu.com/fortbendstar.com/docs/skeeters2017schedule" itemprop="url"><span itemprop="name">Skeeters 2017</span></a></li>
		<li id="menu-item-49432" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49432"><a href="https://issuu.com/fortbendstar.com/docs/skeeters2016schedule" itemprop="url"><span itemprop="name">Skeeters 2016</span></a></li>
		<li id="menu-item-49429" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49429"><a href="http://issuu.com/fortbendstar.com/docs/skeeters2015schedule" itemprop="url"><span itemprop="name">Skeeters 2015</span></a></li>
		<li id="menu-item-49430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49430"><a href="http://issuu.com/fortbendstar.com/docs/skeeters2014schedule" itemprop="url"><span itemprop="name">Skeeters 2014</span></a></li>
		<li id="menu-item-49431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49431"><a href="http://issuu.com/fortbendstar.com/docs/skeeters2013schedule" itemprop="url"><span itemprop="name">Skeeters 2013</span></a></li>
	</ul>
</li>
	<li id="menu-item-49433" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-49433"><a href="#" itemprop="url"><span itemprop="name">55 Days of Summer</span></a>
	<ul class="sub-menu">
		<li id="menu-item-55068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-55068"><a href="https://issuu.com/fortbendstar.com/docs/55days2017" itemprop="url"><span itemprop="name">55 Days 2017</span></a></li>
		<li id="menu-item-50427" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50427"><a href="https://issuu.com/fortbendstar.com/docs/55days2016" itemprop="url"><span itemprop="name">55 Days 2016</span></a></li>
		<li id="menu-item-49434" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49434"><a href="http://issuu.com/fortbendstar.com/docs/55daysummer2015" itemprop="url"><span itemprop="name">55 Days 2015</span></a></li>
	</ul>
</li>
	<li id="menu-item-50428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-50428"><a href="https://issuu.com/fortbendstar.com/docs/2016seniorlivingspring" itemprop="url"><span itemprop="name">2016 Senior Living &#8211; Spring</span></a></li>
</ul>
</li>
<li id="menu-item-56975" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-56975"><a href="http://fortbendstar.com/classifieds/" itemprop="url"><span itemprop="name">Classifieds</span></a>
<ul class="sub-menu">
	<li id="menu-item-56977" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56977"><a href="http://fortbendstar.com/place-an-ad/" itemprop="url"><span itemprop="name">Place an Ad</span></a></li>
	<li id="menu-item-56976" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56976"><a href="http://fortbendstar.com/jobs/" itemprop="url"><span itemprop="name">Jobs</span></a></li>
	<li id="menu-item-56980" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56980"><a href="http://fortbendstar.com/classifieds/" itemprop="url"><span itemprop="name">Word Ads</span></a></li>
</ul>
</li>
<li id="menu-item-56965" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-56965"><a href="http://fortbendstar.com/about/" itemprop="url"><span itemprop="name">Contact Us</span></a>
<ul class="sub-menu">
	<li id="menu-item-56972" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-56972"><a href="http://fortbendstar.com/about/" itemprop="url"><span itemprop="name">Staff Contacts</span></a></li>
	<li id="menu-item-56969" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56969"><a href="http://fortbendstar.com/PDF/starmediakit2017.pdf" itemprop="url"><span itemprop="name">Fort Bend Star Rates</span></a></li>
	<li id="menu-item-56970" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56970"><a href="http://fortbendstar.com/PDF/fbbjmediakit2017.pdf" itemprop="url"><span itemprop="name">Business Journal Rates</span></a></li>
	<li id="menu-item-56971" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-56971"><a href="mailto:editor@fortbendstar.com" itemprop="url"><span itemprop="name">Press Releases</span></a></li>
</ul>
</li>
</ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://fortbendstar.com/">Fort Bend Southwest Star Newspaper</a></p><p class="site-description" itemprop="description">Local News, Classifieds, Real Estate for Sugar Land, Richmond, Stafford, Missouri City, Katy</p></div></div></header><div class="site-inner"><!--<div class="wallpaperdiv">
<img src="http://fortbendstar.com/wp-content/uploads/2017/12/businessjournal.jpg"></a></div>--><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-58221 post type-post status-publish format-standard category-letters entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">No need for vulgar free speech</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2018-01-03T09:31:56+00:00">January 3, 2018</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="http://fortbendstar.com/author/staffreports/" class="entry-author-link" itemprop="url" rel="author"><span class="entry-author-name" itemprop="name">Staff Reports</span></a></span> <span class="entry-comments-link"><a href="http://fortbendstar.com/no-need-for-vulgar-free-speech/#respond">Leave a Comment</a></span> </p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-medium" id="share-before-58221"><div class="googlePlus" id="googleplus-before-58221" data-url="http://fortbendstar.com/no-need-for-vulgar-free-speech/" data-urlalt="http://fortbendstar.com/?p=58221" data-text="No need for vulgar free speech" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-before-58221" data-url="http://fortbendstar.com/no-need-for-vulgar-free-speech/" data-urlalt="http://fortbendstar.com/?p=58221" data-text="No need for vulgar free speech" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-58221" data-url="http://fortbendstar.com/no-need-for-vulgar-free-speech/" data-urlalt="http://fortbendstar.com/?p=58221" data-text="No need for vulgar free speech" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="pinterest" id="pinterest-before-58221" data-url="http://fortbendstar.com/no-need-for-vulgar-free-speech/" data-urlalt="http://fortbendstar.com/?p=58221" data-text="No need for vulgar free speech" data-title="Pin" data-reader="Pin this" data-count="%s Pins"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-before-58221').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'http://fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-before-58221').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'http://fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-58221').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'http://fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  twitter: { via: 'FtBendAthletics' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#pinterest-before-58221').sharrre({
										  share: {
										    pinterest: true
										  },
										  urlCurl: 'http://fortbendstar.com/wp-content/plugins/genesis-simple-share/lib/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('pinterest');
										  }
										});

				});
		</script><p class="p1">Dear Editor,</p>
<p class="p1">I read your editorial about the Trump hater and her husband. I understand the need for free speech but not the need for vulgar free speech, especially where children can see it. Isn’t there an obscenity law?  I also don’t see the need to show the crybabies that don’t like the fact that Trump won the election fair and square. Nobody is asking them to like President Trump but they should respect the office of the President . These two people ( I use that term loosely) have no class at all.  Mrs. Fonseca said she had 12 children &amp; this is the way she is raising them? Where is CPS?</p>
<p class="p1">I also don’t understand why you give this loser of a husband and wife team free publicity. There must be other quality stories your paper could cover during this time of the year about acts of unrequired kindness people do for one another in the aftermath of Harvey, the floods, the shootings and other things that have happened during the past year. Your paper put the two of them on the front page?</p>
<p class="p1">If stories like this are published because the news media likes to sensationalize the news, then you have succeeded. Even if you succeeded, you have lowered yourself to the level of these two and in doing that, you ultimately have failed to maintain your own decency and integrity.</p>
<p class="p1">Larry Faust</p>
<p>Missouri City</p>
<p class="p1">P.S. A Vietnam veteran who voted for both President Trump and Troy Nehls and is proud of it. That woman and her husband are a disgrace to the people and the great state of Texas.</p>
<p class="p1">I am not expecting you to post this.</p>
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="http://fortbendstar.com/category/community/letters/" rel="category tag">Letters</a></span> </p></footer></article><h2 class="screen-reader-text">Reader Interactions</h2>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/no-need-for-vulgar-free-speech/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="http://fortbendstar.com/wp-login.php?redirect_to=http%3A%2F%2Ffortbendstar.com%2Fno-need-for-vulgar-free-speech%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-2" class="widget widget_search"><div class="widget-wrap"><h3 class="widgettitle widget-title">Search this site</h3>
<form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://fortbendstar.com/" role="search"><meta itemprop="target" content="http://fortbendstar.com/?s={s}"/><label class="search-form-label screen-reader-text" for="searchform-5a4d29e16a0876.82147119">Search the site ...</label><input itemprop="query-input" type="search" name="s" id="searchform-5a4d29e16a0876.82147119" placeholder="Search the site ..." /><input type="submit" value="Search" /></form></div></section>
<section id="text-34" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><a href="https://issuu.com/sugarlandnewcomerguide.com/docs/fortbend0103"><img src="http://fortbendstar.com/wp-content/uploads/2018/01/0103digital.jpg" /></a></p>
</div>
		</div></section>
<section id="text-33" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><p><a href="http://www.fortbendstar.com/donation"><img src="http://fortbendstar.com/wp-content/uploads/2017/12/donationpromo.jpg" /></a></p>
<p><!--<a href="MAILTO:diane@fortbendstar.com"><img src="http://fortbendstar.com/wp-content/uploads/2017/11/promo3.jpg" /></a>--></p>
<p><a href="https://www.facebook.com/FortBendStar"><img src="http://fortbendstar.com/wp-content/uploads/2017/12/facebook.jpg" /></a></p>
<p><a href="https://twitter.com/FtBendAthletics"><img src="http://fortbendstar.com/wp-content/uploads/2017/12/twitter.jpg" /></a></p>
</div>
		</div></section>
<section id="media_image-2" class="widget widget_media_image"><div class="widget-wrap"><img width="321" height="347" src="http://fortbendstar.com/wp-content/uploads/2017/12/featuresideb1210.jpg" class="image wp-image-57995  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="http://fortbendstar.com/wp-content/uploads/2017/12/featuresideb1210.jpg 321w, http://fortbendstar.com/wp-content/uploads/2017/12/featuresideb1210-278x300.jpg 278w" sizes="(max-width: 321px) 100vw, 321px" /></div></section>
<section id="media_image-3" class="widget widget_media_image"><div class="widget-wrap"><img width="321" height="347" src="http://fortbendstar.com/wp-content/uploads/2017/12/featureside1210.jpg" class="image wp-image-57994  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="http://fortbendstar.com/wp-content/uploads/2017/12/featureside1210.jpg 321w, http://fortbendstar.com/wp-content/uploads/2017/12/featureside1210-278x300.jpg 278w" sizes="(max-width: 321px) 100vw, 321px" /></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap">Copyright &#x000A9;&nbsp;2018 Fort Bend Star </div></footer></div>
		<!-- BNE Flyouts -->
		<div class="bne-flyout-wrapper">

			<div class="flyout-overlay flyout-overlay-ios"></div>


			<div id="flyout-container-id-56984"><div class="flyout-trigger-id-56984 flyout-trigger trigger-left  trigger-button" style="top: 40%; background-color: #333333; ">Click Here</div>
					<!-- Build Flyout Content -->
					<div id="flyout-content-id-56984" class="sidr">
						<div class="flyout-content push">

							<!-- Flyout Header Buttons -->
							<div class="flyout-header-buttons">
								<div class="flyout-close-button flyout-close"><i class="bne-icon-cancel"></i></div>
															</div>


							<div class="flyout-content-body"><h2>Tab Editions</h2>
<h3>Fancy Display</h3>
<div class="modal-center"><img src="http://fortbendstar.com/asdfeature/188x150.jpg"></div>
<div class="modal-center"><img src="http://fortbendstar.com/asdfeature/188x150.jpg"></div>
</div>
							<div class="clear"></div>
						</div><!-- .flyout-content (end) -->
					</div><!-- #flyout-content-ID.sidr (end) -->


				</div><!-- #flyout-container (end) -->


			
		</div><!-- .bne-flyout-wrapper (end) -->

	<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/fortbendstar.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.2'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-includes/js/comment-reply.min.js?ver=4.9.1'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/themes/genesis/lib/js/menu/superfish.js?ver=1.7.5'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/themes/genesis/lib/js/menu/superfish.args.js?ver=2.5.3'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/themes/genesis/lib/js/skip-links.js?ver=2.5.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-primary",".nav-header",".nav-secondary"]}};
/* ]]> */
</script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/themes/magazine-pro/js/responsive-menus.min.js?ver=3.2.3'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-includes/js/wp-embed.min.js?ver=4.9.1'></script>
<script type='text/javascript' src='http://fortbendstar.com/wp-content/plugins/bne-flyout/assets/js/jquery.sidr.min.js?ver=1.3.8'></script>
<script type='text/javascript'>
						jQuery(document).ready(function($){
						    $(".flyout-trigger-id-56984").sidr({
								name: "flyout-content-id-56984",
								side: "left",
								displace: true,
								speed: 300,
								onOpen: function(name) {
									$(".flyout-overlay").fadeIn(300).toggleClass("active");
									$("#flyout-content-id-56984").toggleClass("flyout-open");
								    $(".flyout-overlay, .flyout-close").on("click", function() {
										$.sidr("close", "flyout-content-id-56984");
									});
								},
								onClose: function(name) {
									$(".flyout-overlay").fadeOut(300).toggleClass("active");
									$("#flyout-content-id-56984").toggleClass("flyout-open");
								}
						    });
						});
					

		var flyout_overlay = document.getElementsByClassName("flyout-overlay")[0];
		flyout_overlay.addEventListener("touchmove", function(e) {
			e.preventDefault();
		}, false);
	
</script>
</body></html>
